今天搭建一个SSMdemo,在编译java代码提示java版本过低,具体报错如下:

信息:javac 1.8.0_112 was used to compile java sources
信息:Some files were changed during the build. Additional compilation may be required.
信息:2019/1/4 11:59 - 编译完成有 2 个警告 in 798ms
警告:java: 源值1.5已过时, 将在未来所有发行版中删除
警告:java: 要隐藏有关已过时选项的警告, 请使用 -Xlint:-options。

解决办法:
1.打开项目结构(快捷键ctrl+alt+shift+S
首先保证你本地的java版本是1.5+,建议1.8+
仔细核对下面这几个地方是否正确。
22469-zioizh0xvbp.png

64781-1tbenlv0jfyj.png

79790-5i0odgfoleb.png

2.确认没问题后,打开设置(快捷键ctrl+alt+S
查看编译器是否是设置的1.8+
03966-xl1s8srzi4i.png

3.最后重启项目,搞定!

扫描下面二维码,给博主打赏点吧~

微信

微信

支付宝

支付宝


>作者:Lcry
>本文链接:https://www.51it.wang/ll/1039
>商业转载请联系作者获得授权,非商业转载请注明本文出处及文章链接

带符号 * 的表示必填项