这篇文章距离上次修改已过半年,其中的信息真实性可能已经有所发展或是发生改变,请自行分辨。

事由:昨晚上迁移笔记栈(https://note.51it.wang)到腾讯云主机上,发现mindoc需要glibc-2.14,服务器是glibc-2.12,于是需要升级。

CentOS默认的glibc版本为2.12.1, 升级至glibc-2.14.1的方法, 如下
1.查看当前glibc版本:
ls -l /lib64/libc.so.6

2.下载gblic2.14,wget若下载失败建议本机网络下载通过xftp上传:
wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz

3.解压:
tar zxvf glibc-2.14.tar.gz

4.安装:
cd glibc-2.14
mkdir build && cd build /在源码文件夹下创建一个build文件夹,编译生成的文件都放在此文夹下/
../configure --prefix=/usr /指定路径/
make /编译,时间有点久耐心等/
make install /安装,使用root权限/

最后会遇到一个报错,可忽视:

/usr/bin/ld: cannot find -lnss_test1
collect2: ld returned 1 exit status
Execution of gcc -B/usr/bin/ failed!

5.检查:
ls -l /lib64/libc.so.6

至此升级完成。

扫描下面二维码,给博主打赏点吧~

微信

微信

支付宝

支付宝


作者:Lcry
本文链接:https://www.51it.wang/ll/150
商业转载请联系作者获得授权,非商业转载请注明本文出处及文章链接

带符号 * 的表示必填项